ns(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
NS(4)                     NetBSD Programmer's Manual                     NS(4)


NAME
ns - Xerox Network Systems(tm) protocol family
SYNOPSIS
options NS options NSIP pseudo-device ns
DESCRIPTION
The NS protocol family is a collection of protocols layered atop the Internet Datagram Protocol (IDP) transport layer, and using the Xerox NS address formats. The NS family provides protocol support for the SOCK_STREAM, SOCK_DGRAM, SOCK_SEQPACKET, and SOCK_RAW socket types; the SOCK_RAW interface is a debugging tool, allowing you to trace all packets entering, (or with toggling kernel variable, additionally leaving) the local host.
ADDRESSING
NS addresses are 12 byte quantities, consisting of a 4 byte Network num- ber, a 6 byte Host number and a 2 byte port number, all stored in network standard format. (on the VAX these are word and byte reversed; on the SUN they are not reversed). The include file <netns/ns.h> defines the NS address as a structure containing unions (for quicker comparisons). Sockets in the Internet protocol family use the following addressing structure: struct sockaddr_ns { short sns_family; struct ns_addr sns_addr; char sns_zero[2]; }; where an ns_addr is composed as follows: union ns_host { u_char c_host[6]; u_short s_host[3]; }; union ns_net { u_char c_net[4]; u_short s_net[2]; }; struct ns_addr { union ns_net x_net; union ns_host x_host; u_short x_port; }; Sockets may be created with an address of all zeroes to effect ``wildcard'' matching on incoming messages. The local port address spec- ified in a bind(2) call is restricted to be greater than NSPORT_RESERVED (=3000, in <netns/ns.h>) unless the creating process is running as the super-user, providing a space of protected port numbers.
PROTOCOLS
The NS protocol family supported by the operating system comprises the Internet Datagram Protocol (IDP) idp(4), Error Protocol (available through IDP), and Sequenced Packet Protocol (SPP) spp(4). SPP is used to support the SOCK_STREAM and SOCK_SEQPACKET abstraction, while IDP is used to support the SOCK_DGRAM abstraction. The Error pro- tocol is responded to by the kernel to handle and report errors in proto- col processing; it is, however, only accessible to user programs through heroic actions.
SEE ALSO
byteorder(3), gethostbyname(3), getnetent(3), getprotoent(3), getservent(3), intro(3), ns(3), idp(4), intro(4), nsip(4), spp(4) Internet Transport Protocols, Xerox Corporation document XSIS, 028112. An Advanced 4.3 BSD Interprocess Communication Tutorial.
HISTORY
The ns protocol family appeared in 4.3BSD. NetBSD 1.6 November 30, 1993 2
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.