dirent(5) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
DIR(5)                    NetBSD Programmer's Manual                    DIR(5)


NAME
dir, dirent - directory file format
SYNOPSIS
#include <sys/types.h> #include <sys/dir.h>
DESCRIPTION
Directories provide a convenient hierarchical method of grouping files while obscuring the underlying details of the storage medium. A directo- ry file is differentiated from a plain file by a flag in its inode(5) en- try. It consists of records (directory entries) each of which contains information about a file and a pointer to the file itself. Directory en- tries may contain other directories as well as plain files; such nested directories are referred to as subdirectories. A hierarchy of directo- ries and files is formed in this manner and is called a file system (or referred to as a file system tree). Each directory file contains two special directory entries; one is a pointer to the directory itself called dot `.' and the other a pointer to its parent directory called dot-dot `..'. Dot and dot-dot are valid pathnames, however, the system root directory `/', has no parent and dot- dot points to itself like dot. File system nodes are ordinary directory files on which has been grafted a file system object, such as a physical disk or a partitioned area of such a disk. (See mount(8).) The directory entry format is defined in the file <dirent.h>: #ifndef _DIRENT_H_ #define _DIRENT_H_ /* * A directory entry has a struct dirent at the front of it, containing its * inode number, the length of the entry, and the length of the name * contained in the entry. These are followed by the name padded to a 4 * byte boundary with null bytes. All names are guaranteed null terminated. * The maximum length of a name in a directory is MAXNAMLEN. */ struct dirent { u_long d_fileno; /* file number of entry */ u_short d_reclen; /* length of this record */ u_short d_namlen; /* length of string in d_name */ #ifdef _POSIX_SOURCE char d_name[MAXNAMLEN + 1]; /* maximum name length */ #else #define MAXNAMLEN 255 char d_name[MAXNAMLEN + 1]; /* maximum name length */ #endif }; #ifdef _POSIX_SOURCE typedef void * DIR; #else #define d_ino d_fileno /* backward compatibility */ /* definitions for library routines operating on directories. */ #define DIRBLKSIZ 1024 /* structure describing an open directory. */ typedef struct _dirdesc { int dd_fd; /* file descriptor associated with directory */ long dd_loc; /* offset in current buffer */ long dd_size; /* amount of data returned by getdirentries */ char *dd_buf; /* data buffer */ int dd_len; /* size of data buffer */ long dd_seek; /* magic cookie returned by getdirentries */ } DIR; #define dirfd(dirp) ((dirp)->dd_fd) #ifndef NULL #define NULL 0 #endif #endif /* _POSIX_SOURCE */ #ifndef _KERNEL #include <sys/cdefs.h> #endif /* !_KERNEL */ #endif /* !_DIRENT_H_ */
SEE ALSO
fs(5), inode(5)
HISTORY
A dir file format appeared in Version 7 AT&T UNIX. NetBSD 1.6 April 19, 1994 2
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.